Senior Member

Rank: 2

Credits
64
Device
0
MIUI Version
0
Online time
5 Hours
Send PM

[Q & A] Xiaomi Xiaofang 1080p WiFi IP Camera - Connection Timed Out issue

[ Promote]
16435 25 |
00:53, Jul-12-2017 | From PC
|
|
Go to reply no.
Hello Friends,


Iam from India and i recently purchased 3 pieces of "Xiaomi Xiaofang 1080p WiFi IP Camera". While doing the initial setup, as instructed, i selected "Mainland China" as the location in Mi Home and while trying to establish the connection with the Wifi, the connection always fails at 89% giving the error - Connection Timed out. Despite repeated trials still iam not able to fix this issue and all my 3 cameras are of no use now.


I had also tried the wifi hotspot technique. The only thing which is different in my case is my hotspot is having password (i dont think that having password is a problem) . When trying to establish the wifi connection from MI Home (latest version app) , its still failing at 89% and gives "Connection timed out" error. Despite repeated trials, its the same condition.
Note: This is the new model, the one without needle/pin for setup. The MAC ID starts with 34.

Its very strange for me that for some of the people it worked, but for me the same tricks dont work :(
Please help.
Favorite5 Share

Gold Member

Rank: 3Rank: 3

Credits
381
Device
0
MIUI Version
V8.2.16.0.0.MAGCNDH
Online time
4 Hours
Send PM

Rooster Year of 2017

02:05, Jul-12-2017 | From Mi 5s
|
have same problem with my. but mine was working and then stopped working so i removed and tried Connect again. timeout @ 89%

Senior Member

Rank: 2

Credits
64
Device
0
MIUI Version
0
Online time
5 Hours
Send PM
 Author| 19:13, Jul-12-2017 | From PC
|
This post was edited by DineshKumarDora at 19:16, Jul-12-2017

Finally!!! I found the solution after so much research.
NOTE: For people who are NOT FROM EUROPE or US, can make use of my solution, that worked for me.

1st: You need set the app to Mainland China. (Go to profile->Tap on Locale to change)
2nd: Use any extra mobile device to download Mi Home app
3rd: Use current phone with 4G to setup hotspot without password. - If you setup the hotspot with password, it will fail.
4th: Follow instruction to setup, when prompt for WiFi you need to select your "phone hotspot" and once scan QR code it will start loading and listen carefully if the speaker voice out twice it's for the WiFi set up successful and pair up successful. (If it voice out twice but connection failed, just re-try once and it will connect right away).
Lastly: once you done it just update cam firmware and then go back to use your current phone. Hold the setup button on camera and reset it. Then setup cam with house WiFi. NOTE: While entering the network credentials, dont go with saved passwords, TYPE THEM AGAIN. It saves invalid password.

Connection will be established immediately. If not try once more and it will connect.
No extra mobile phone needed anymore.
This trick also works with UPDATED APP as well. I am using with latest cam firmware and latest mobile app.

Junior Member

Rank: 1

Credits
22
Device
0
MIUI Version
0
Online time
0 Hours
Send PM
00:09, Jul-13-2017 | Via mobile
|
Finally a working fix! Thanks man for sharing this. I was using my xiaofang camera for just 5 days when suddenly that "Connection timed out" issue came up just when I tried to connect it directly thru the device and set it up back again using my wifi then it wont connect already. I find it very useful in monitoring my kids while I am at work and decided to buy 2 more for their room and out the porch until when the issue happened I almost returned it to where I bought it for defectiveness but decided to look out for a fix first b4 trying to return it. Now thanks to you man Ive decided to buy another 2 pcs. :)  

Senior Member

Rank: 2

Credits
64
Device
0
MIUI Version
0
Online time
5 Hours
Send PM
 Author| 00:19, Jul-16-2017 | From PC
|
bootstr4p replied at 2017-7-13 00:09
Finally a working fix! Thanks man for sharing this. I was using my xiaofang camera for just 5 days w ...

try this trick first with your existing ones and then decide to buy the rest 2, if it works for u... :)

Junior Member

Rank: 1

Credits
24
Device
0
MIUI Version
0
Online time
2 Hours
Send PM
01:17, Jul-28-2017 | Via mobile
|
Hi guys, I followed the steps and it worked till step 4. For the last step, what do u mean by hold the button to reset? Do u mean reset to default factory (hold till orange light turn off and wait for it to start blinking again)? I tried to add it again to my wifi after and again timed out. Anything I might miss?

Senior Member

Rank: 2

Credits
64
Device
0
MIUI Version
0
Online time
5 Hours
Send PM
 Author| 23:52, Aug-12-2017 | From PC
|
Ducleown replied at 2017-7-28 01:17
Hi guys, I followed the steps and it worked till step 4. For the last step, what do u mean by hold t ...

Yes you have to factory reset the camera.After connecting to mobile hotspot, did u update ur cam firmware via check for updates in Mi home app?
Only after updating the cam firmware, u will be able to connect to your home wifi.
Do let me know.

Junior Member

Rank: 1

Credits
24
Device
0
MIUI Version
0
Online time
2 Hours
Send PM
14:33, Sep-03-2017 | Via mobile
|
Didn't work for me bro. Once it's my house Wi-Fi it just not connecting :(

Diamond Member

http://niezzam.blogspot.my/

Rank: 5Rank: 5

Credits
1043
Device
Mi Pad 2
MIUI Version
7.11.8
Online time
29 Hours
Send PM

Mijia Qi CycleMi HeadphonesMi Bluetooth SpeakerMi ScaleUnlock MedalMijia Story TellerMIUI Devices ContestI Love MIUIFantastic!Mi Pad 2Xiaomi Mi 6MIUI 9Super TuesdayMIUI 7th AnniversaryMIUI 2017Rocket to FutureForum Contest LoverPioneer of MIUI English Forum MIUI FollowerStar Of TechnologyMIUI Halloween 2017MIUI ExpertMi Story TellerMi Lover MedalMost Active MIUIerAndroid Guru

19:12, Oct-22-2017 | From PC
|
try allow port 443 in your router. mine working like charm after going thru firewall log file
- Tutorial For Flashing ROM on Mi 6 & Mi Pad 2 -
https://niezzam.blogspot.my/

Junior Member

Rank: 1

Credits
22
Device
0
MIUI Version
0
Online time
1 Hours
Send PM
22:08, Oct-28-2017 | From PC
|
sh4rk replied at 2017-10-22 19:12
try allow port 443 in your router. mine working like charm after going thru firewall log file

Hi, Can you please explain how to open this port?
I tried to connect the camera over WIFI at a friends house and it worked, and it doesn't work at my house. any suggestions?

Credits Management

Quick Reply Top Return to the list