Senior Member

Rank: 2

Credits
34
Device
0
Online time
1 Hours
Send PM

[Q & A] Xiaomi Vacuum Robot Connection Time Out

[ Promote]
3790 4 |
20:59, Jan-15-2018 | From PC
|
|
Go to reply no.
Folks
Ive read similar posts but the solutions do not appear to work for me.  I am trying to configure my Xiami Mirobot Vacuum.  So far the sequence of events are:
1) I have installed Mi Home on my Samsung J7 phone
2) I have configure locale to be China Mainland and language to be English
3) Wifi  on the robot is on and the wifi light has slow pulse
4) I sign on to Mi Home on my samsung
5) I click on the plus at the top right corner to add device.  It shows My Robot Vacuum67F2
6) I click on My Robot Vacuum67F2 and it asks me to sign on to my network
7) I sign on to my network and it gets ti 26% saying just a sec
8) I get a connection to the wifi from "my robot vacuum67f2"
9) i get a connection to my network
10) at 45% approx, it says "updating connection status, just a sec" and wireless light flashes fast
11) at 90% I get connection timed out

Can someone please help me to overcome this as I have run out of ideas (and it is so frustrating)

Thanks,
Michael
Favorite1 Share

Senior Member

Rank: 2

Credits
34
Device
0
Online time
1 Hours
Send PM
 Author| 19:17, Jan-16-2018 | From PC
|
Folks
For anybody finding this thread, the problem is resolved after performing a number of activities:
1) Hard reset on the Vacuum
2) Installed the latest version of the app on my phone
3) Turned off MAC filter on the router
4) Disabled bridge restrict
5) Cleared DNS history in Chrome on the Phone.

Good Luck.....

Rated by 1 person   Experience Reason  

mvnaidu88 + 8 Thanks!

Experience +8  View Rating Log

Junior Member

Rank: 1

Credits
22
Device
0
Online time
0 Hours
Send PM
10:52, Jan-18-2018 | Via mobile
|
Hi Moolie, I've got the exact same problem but it hasn't been resolved. How did you do a hard reset on the vacuum?

Senior Member

Rank: 2

Credits
33
Device
0
Online time
2 Hours
Send PM
02:49, Feb-15-2018 | From PC
|
This post was edited by Jak1907 at 03:24, Feb-15-2018

I have been noticing a lot of this problem with xiaomi recently. We use a different vacuum, Eufy robovac. But it doesn't support wifi so I guess we're safe from this one. I just find it a bit frustrating that it can't run long, unlike the xiaomi. I hope your problems get fixed soon!

Senior Member

Rank: 2

Credits
35
Device
Others
Online time
1 Hours
Send PM
19:43, Nov-30-2018 | From PC
|

Finally solved for me!!
You need a second Android device with hotspot, setting up with the same SSID and Password of your home wifi.
0-switch off home wifi
1- reset robot wifi
2-connect your main android device to the hotspot of the second
3-log in to MiHome, set to mainland China
4-setup Robot to hotspot network
5-switch off Hotspot
6-switch on Home Wifi
7-the Robot will now connect to the Home WiFi

Enjoy!

Credits Management

Quick Reply Top Return to the list